Tasker löst Discomodus nicht aus

Wenn ich in Tasker/Automate das HueEssentials Plugin wähle, dann Unterhaltungsprogramm starten, als Typ “Discomodus” und dann meine Entertainment-Zone wähle, dann schaltet sich das Licht zwar aus, reagiert aber nicht auf Musik.
Nach kurzer Zeit wird dann eine Meldung angezeigt, dass Hue Essenstials wiederholt beendet wird.
Wenn ich dasselbe über die Hue Essenstials App mache, funktioniert es perfekt

Could you please share your crash identifier? See: Crash identifier


Thanks! Is there any other app in the background that could be using the microphone? Think about a recorder app, music visualisation apps, live lyrics apps, etc.

No, there is no other app using the mic,
But im on Android 11 and ive just seen this:

Which means your App is not requesting permission for background mic use, so it cant access it when started from plugin
Please fix it so it does request mic background permission.

Hue Essentials is not considered in the background by Android, because it shows a persistent notification when using the microphone.

Unfortunately, I have not figured out the cause of the issue yet. It works for everyone else, but for some reason it fails on your device.

Can you try granting the Tasker app the microphone permission?

Do you have any type of battery optimisation enabled for Hue Essentials or Tasker? If so, can you please disable that for testing?

Hey there,
it may be this issue is still around. Cause i’m running into the same failure.

Ive checked everything twice. No running apps with mic permission.
I’ve already cleared the cache, uninstalled and installed Hue Essentials.

Hue essential has full permission for using the mic, the cam and also has full permission to run in the backround.

The phone tells me that the app is running and using the microphone but theres no response from the it.

Currently I’m running android 13 on the Phone. Mybe there is a workaround.