Huawei Watch GT3 app stuck on loading screen

I have the same issue. Only black screen on watch (gt3). Any solution?

1 Like

Thanks @troopa123 and @Mpxxl for letting me know. Could you please provide feedback to the following questions?

  • What type of bridge(s) do you have connected to your phone?
  • What are the model ID and Android version of your phone?

Hi Thomas,

thanks for your reply.

I’m using
bridge version BSB002
Software version 1.49.1949203030
with a Xiaomi Mi 10T Pro
Android 11 MIUI Version 12.5.10
Huawei GT3 with latest firmware
For Hue Essentials energy mode is disabled, autostart enabled.


1 Like

bridge version BSB002
Software version 1.49.1949203030
Huawei mate 20 pro
Android 10 Emui 11.0.0
Huawei GT3 with latest firmware

1 Like

After update still not working.

1 Like

Thanks all for the feedback, I am currently looking into it.

@Mpxxl can you please confirm whether you have the Huawei Watch option enabled in Hue Essential settings on your phone? Please find the instructions here: Where can I download Hue Essentials for Huawei watches?

The watch app should have shown these instructions, but due to a bug that doesn’t happen currently.

Ok. Now is working. Thanks.
At first I had app from Google Play. Now I installed once again from App Gallery.

1 Like

@Mpxxl great to hear. In a future update I will add support for the Google Play version, too. But for now you have to use the version from Huawei AppGallery.

Note that you can install both versions at the same time on your phone, but they will both be called “Hue Essentials”, so it could be a bit confusing.

I am still looking into the loading issue that @troopa123 is experiencing.

Yes, I have both version. (For GP version I bought support for Wear OS)

thank you
i have the app from the huawei store and also set up the clock in hue essentials
Most of the time the clock only shows “Loading” - on my xiaomi mi 10t pro i disabled the energy saving functions

If you are still experiencing issues, please try the latest version available on the Huawei App Gallery for the phone and watch. That update contains a lot of fixes for the connection issues.

Hi. I have an huawei watch gt 3 and a samsung galaxy note 8. I cant connect my watch with hue essentials. I already tried to reinstall both apps, but it does not work. Is there anything i could do?

@Purple_Haze_92 did you install Hue Essentials on your phone from Huawei AppGallery instead of the Play Store? See: Where can I download Hue Essentials for Huawei watches?

Yes, but i need the app on my phone and my Smartwatch. Or am i wrong with that?

Or did u mean i should download the app for my phone via health?

Yes, that is correct, you need the app on both your phone and your watch.

However, Hue Essentials on your phone must be installed from Huawei AppGallery instead of Google Play. Support for the Google Play version may be added in the future.

Did you also open Hue Essentials on your phone, open the left menu, go to Settings, and enable the setting Huawei Watch? This is very important.

What do you see on your watch?

Thx. That solved my problem. Didnt know that i have to install it from the appgalery. That was a little bit confusing to me. But now it works.

Thank you

Thanks for letting me know you got it working. I will try and improve this in the future, but for now you will have to download it from AppGallery.

I have the above mentioned problem. But still with all solutions I was until now not able to get my Watch GT3 connected to the Hue Essentials.
Identifier: 7cb2096d-d8e1-47e8-a93e-9f114de43347
I hope some body can help me.
Phone: Redmi Note 11 Pro 5G
Android: 12 SKQ.211006.001
MIUI: Global
Hue Bridge: BSB002 - 1957200040

In Huawei AppGallery disappeared folrom watch Hue Essentials. Bought bulb to try, because see that app in AppGallery, after bought now watching and don’t have that app anymore…