Unable to connect/pair app with diyhue bridge add-on HA


I’m trying to succesfully install and pair the diyhue add-on with hue essentials.
However I’m unseccesfull.

It seems that I may partly pair the Hue essential app with the bridge, but only if I manually write the IP-address even though the bridge shows up in the app without manually adding it, but it still do not work correctly since it lose connection directly after.

What I’ve tried so far.

  1. If I try to add the DiyHue bridge “the normal way” by pressing the device within the app and then clicking the “Link APP” in the browser the app says
    “Unable to connect to the bridge, check the internet connection”, but I have connection.
  1. If I in the other way add the bridge the manual way , writing the IP address and port 80 and then press “Link APP” in the browser it connects. But if I press anywhere within the app the app refresh and says that the DiyHue Bridge is disconnected and if i press connect I get
    “Unable to connect. Couldn’t connect to the bridge, verify the internet connection”, but I have connection.
    I never get a request to use a password either, if I know should get that within Hue essentials too?
  1. If I instead try to pair it with the Hue app, it just won’t pair I press the pair button within the browser but nothing happens.

The only program I know that may conflict with the add-on is the duckdns installation I have, which I have disabled and taken away the redirection in the router for.

Any ideas on how to resolve this what the problmen may be?
any help would be greatly appreciated

HA guide diyhue add on

1 Like

Did you ever figure this out? I am having the same issue/symptoms as you.

Anyone figured this out?

No I did never solved it, if someone do please enlighten us

I have a similar issue. I found an issue in the code, where DiyHue will configure a gateway that is not necessarily the correct one. I had an issue that seems very similar.

This is the first time I’ve looked in this codebase, so I’m not familiar with much going on, and it’s entirely possible that this is irrelevant.

For others who have experienced the issue, can you post your network configuration? Please provide:

  1. Network CIDR or range (linux: ip addr show <your_device> | grep 'inet ' — run from a host with direct network interface access)
  2. Gateway IP (linux: ip route | grep default will give it — run from a host with direct network interface access)
  3. The netmask and gateway from diyhue config (grep -E '(gateway|netmask):' /config/diyhue/config.yaml when using the HA SSH addon with defaults)

e.g. for me (after tinkering a bit):

  1. ip addr show eno1 | grep 'inet 'inet metric 100 brd scope global dynamic eno1192.168.134.2/22 =, netmask =
  2. ip route | grep defaultdefault via dev eno1 proto dhcp src metric 100 =
  3. grep -E '(gateway|netmask):' /config/diyhue/config.yaml =>

If others in this thread also have divergent network configs, then that is the most likely proximate cause.