Strange Behavior with HUE Motion Sensor and Conbee2

Hi,
i am expieriencing a strange behavior of a HUE Motion Sensor which is connected to a Conbee2 Stick and Deconz.
i have created several time slots in hue Essentials for the motion sensor. One slot from 6:00 to 23:00 activates a scene (Bright) and another Slot from 23:00 to 6:00 activates another Scene (night).
For “No Motion” i added only one Rule “Dim & Switch off” after two Minutes.
This works, but…
If i add for “no Motion” a second Timeslot like in the “motion” Tab from 23:00 to 6:00 to dim & Switch off after 30 Seconds, the lights will not be switched off anymore. Not at Daytime, neither at Night.

I know that there are some Issues with the Motion Sensor integration, but is this behavior known?

Regards,
Frank

I have similar strange behaviours with HUE motion sensors and Conbee/Raspbee. The only way I got it to work was by creating Rules in the web app of the raspbee (phoscon), rules created in Hue essentials did turn the lights on but never off again.

Thats not a solution for my use case. the possibilities to configure a motion detector in the phoscon app are unfortunately very limited. e.g. you cannot have different scenes activated depending on the time

Hi, thanks for the detailed bug report!

I was able to reproduce the issue and am looking into it. It appears that rules are not always triggered on deCONZ but they should be. It is caused by the time condition, which explains why it works fine for you without using time slots for no-motion. See issue: https://github.com/dresden-elektronik/deconz-rest-plugin/issues/2148

1 Like

Hello,

Thank you for your support. i have read the github issue and think that it seems to be a problem in deconz api. I hope that this problem can be fixed soon
i have an additional info about the problem. i have to specify the times for the Motion Sensor profiles in the app in GMT. So if I want a Sensor profile to be active from 6am to 11pm CEST I have to set 3 to 21 in Hue Essentials.

This is not normal. Please check the time zone of your bridge. You can find it in Hue Essentials by going to the devices tab, select your bridge, and set the correct time zone.

Found the Problem: I run Deconz as a Docker Container on a Synology NAS. I had to add an additional Timezone environment variable to the container to set the correct timezone. It seems that the timezone setting in the Phoscon App (or in HUE Essentials) is not working when Deconz is running as Container.