Disabling/enabling motion sensor when lights are manually switched on/off


I have a motion sensor often in conflict with my scenes.

I managed to have something working by disabling the motion sensor when switching lights on and re-enabling the motion sensor when switching the lights off.

But it’s a lot of configuration, since I have those actions for every single button on the Hue Dimmer Switch, the Tap Dial, Wall Switches, etc. and also it doesn’t work when using toggle buttons in mobile apps.

That’s why I’m trying to achieve something simpler that could work regardless of which app or device is switching the lights on or off. For that, I created the following automations:

  1. When light group goes off, then enable the motion sensor
  2. When light group goes on, then disable the motion sensor

1 works well. The problem is 2 disables the motion sensor when the motion sensor is the one switching the lights on. Because of that, the lights stay on.

Any idea how to solve that? For instance, is there a way to have the below:

  1. Same as above
  2. When light group goes on AND the action wasn’t triggered by the sensor, then disable the motion sensor


1 Like

I’m very interested by the subject, have you find a solution or people have the solution? :blush:

Have a good day, and if I fine a solution I keep you informe!


No clean solution. For now, here is what I’m doing:

  1. I have 3 motion sensors, for 3 different zones

  2. The 3 sensors are configured to activate a “motion detected” scene, only if the lights are off

  3. For every accessory possibly switching the lights on, I toggle the corresponding sensor off before activating a scene. This step is painful because you must think about all ways the lights can be switched on and each time add a rule to Hue Essentials.

  4. In “Automation”, I have 3 generic automations to re-enable the sensors (“When light group goes off, then toggle motion sensor on”). This part is simple and works well, regardless of how the lights are switched off. For instance, when I switch the entire home off, all sensors are re-enabled properly.