Dance Sensation does not work when broadcasting music to a device with Device Audio option

Hello,

I bought the ‘Dance Sensation’ effect. I wanted to play music on my echo while using this effect. I set Audio Source to ‘device audio’ as I am broadcasting the audio from my device to another device. This makes dance sensation do nothing.

I know I could set it to ‘microphone’ but I find this doesn’t work as well as ‘device audio’. Is there no way to make this work in this way? Is it a bug?

This is not possible at the moment. The Device audio option uses the the sound that comes out of the device speaker. What device are you broadcasting to? How are you broadcasting the music?