Hue Essentials Community

Can't connect to hue bridge on Amazon Fire Stick 4k

For the last week or so I have not been able to connect to my hue bridge via hue essentials on either of my Amazon Fire stick 4Ks. I have 2 and they both stopped connecting around the same time. I don’t know that it’s related to the latest update but it seems to have started around then.

The app just never seems to connect to the bridge. For example if I try to use sync none of my entertainment zones show up. On the home page the “home” tile is just constantly loading.

I have tried clearing cache, clearing data, and reinstalling but none of them have helped. When I try to add the bridge again I am unable to. Hue essentials is able to find my bridge but I can’t proceed past “press the push-link button on the bridge.” No matter how many times I press the button it never connects and never proceeds past this screen. I also tried the manual connection but it’s the same problem. I get blocked at the “press the push-link button on the bridge”. I have also tried restarting the bridge but that didn’t help either. My bridge works perfectly other than connecting to hue essentials.

I’m still able to connect to my bridge via hue essentials on my smartphone; the problem only seems to happen on my firesticks.

1 Like

I have the same problem. I can find the hue bridge and on the Screen: “Press the Pair Button” I can press it as many times as i want but it wont work.

Hello and thanks for the feedback. I was able to reproduce the issue and published an update with a fix. The update is currently in review by Amazon, which could take a few days. The new version is 1.28.6. Sorry for the inconvenience caused.

2 Likes

Thank you so much for the help! Really appreciate it!

Amazon just approved the update, please let me know if it works for you.

It works! Thank you so much for the help Thomas! And thank you so much for all the hard work on the app; it is easily the best Hue app out there!

1 Like