Hue Essentials Community

Connect app to Deconz running on Hassio(Home Assistant)

Hey, Im trying to connect the app to Deconz running on Hassio(Home Assistant) but i never successfully connect. Im using the same ip as hassio since the deconz stick is hooked up to the same machine/deconz gui installed. ive tried all the ports listed

Port 80 and 5900 also:

  • (API) Port : 40850
  • WebSocket Port : 8081

It gives me a strange error " exception in http request: error domain:NSURLE…"

If i press OK i still see the user/pass window where i try to type in the credentials but it doesnt seem to let me in etc. I dont find any documentation townards how im suppose to solve this if im running deconz on HA :frowning:

Hi, Hue Essentials should have shown deCONZ in the list automatically (so no connect manuallly needed) but it appears that does not work in your case. What do you see when you open on your phone? It should show the details of your deCONZ setup.

Alternatively, you could use the option to connect manually as you tried already. Just to make sure, if you enter your ipaddress:port in a web browser, does that show the Phoscon app? Did you enter those same values in Hue Essentials?

Thanks for your reply! gives me:

About that - upnp is not supported it seems. When i read about the hassio addon it says this under limitations/known issues:
“The add-on has no UPnP support.”

Any other ideas? :frowning:

What happens when you go to in your web browser? If you see the Phoscon app, then these should be the values you need to enter in Hue Essentials under connect manually. If you do not see the Phoscon app then it could be your deCONZ setup is not working correctly.

Missing UPnP support should not be a problem for Hue Essentials.

thanks for the reply thomas, looks dark tho. does not load in my browser, even tried placing the hassio machine in the DMZ to assure the ports were not the issue and rebooted the entire system

other stuff worth noting:
im using the IOS app of Hue Essentials on the same network as the machine ofcourse and it discovers my hue bridges w/o any issues
i can access the local deconz gui via “” (yes ive tried this ip/port combination aswell)
the local ip wont load in the browser either “”
navigating to sends me to where i see my Conbee device “” and lets me login. this is where ive fetched some of the info even if i dont understand some of the technical stuff on there

1 Like

Hi again, just looked at the documentation and that also confirms the correct port is 40850 for the API. Strange that does not load in your browser, it should show the Phoscon app.

Could you make sure the deCONZ API is actually working? Go to That should return details from your deCONZ. If that does not work, then that explains why Hue Essentials cannot access deCONZ. If that is the case, we would need to find out where to access the API in your case.

How did you install deconz? There are some problems with the official addon since they introduced Ingress support.

Here is how I still connected:

  • in the addons settings (Supervisor -> deconz) Under network set the first port to 40850 (deconz backend):
  • save and restart deconz
  • open up hue essentials when restarted. For me Deconz still wasn’t found automatically but if I entered the ip adress of hassio and 40850 as a port and logged in using the credentials it connected instantly!

Hope this helps!

1 Like

I tried to follow the guide, but if I open the link ( and try to log in, it does not log in for the wrong password.

While if I open the home assistant url ( and use the same password it works.


First you need to set the port as shown in capstan1’s last post. After doing this using the IP, like he advises still didn’t work for me but it did work using the host name: http://hassio.local:40850/ where hassio.local is the hostname I use to access HA.

Nope, on Hueessentials you only can input ip adress so no names and http and / also not working.

When Hueessentials was waiting for the password i gave on Hassio Phoscon autenticate and that works.
But now i could not find the color settings on Hueessentials.

1 Like

What colour settings are you looking for? Could you create a new topic with more details, please?

Is there any way to access the latest version of deconz behind a server? It seems like the 40850 port is not available outside of the machine, just for other hassio addons.

I had the same problem - no bridge, no
After I set the api port 40850 - still no bridge…
Then I tried to change my gateway name and voila the bridge was found automatically. My gateway had a minus “-” before it worked, so I think there are some characters causing problems within the hassio deconz combination.
Hope this helps some of you

1 Like

Thank you, but this didn’t help my problem.
It’s plausible that the 172 adress is not visible outside your server as these are adresses used by Docker for the hassio installation. Somehow I have to ensure that deconz is reachable via :40850 .Maybe I’ll ask the Home Assistant people.

Okay, simple solution:
On the configuration page of the deconz add-on there is an option to forward port 40850. I didn’t see this options until I pushed the reset to defaults button. After this I could connect (manually) from hue essentials.

1 Like